英泰移动通信学校
400-6160-599
咨询热线:
教育引领未来
实时热点

一招教你解决网络工程中20%的配置需求

发表时间:2023-11-04 11:25

现在无论是园区网络还是数据中心网络,链路捆绑是大家都在用的技术点,其中华为的链路汇聚叫Eth-Trunk


Eth-Trunk是一种捆绑技术。将多个物理接口捆绑成一个逻辑接口,这个逻辑接口就称为 Eth-Trunk 接口,捆绑在一起的每个物理接口称为成员接口。Eth-Trunk 技术可以实现增加带宽、提高可靠性和负载分担的功能。


在一个 Eth-Trunk 内,可以实现流量负载分担,同时也提供了更高的连接可靠性和更大的带宽。用户通过对逻辑口进行配置,实现各种路由协议以及其它业务。


以下图为例,两台交换机通过 3 个接口直连,将这 3 个接口捆绑,形成一个 Eth-Trunk 接口,从而实现了增加带宽和提高可靠性的目的。

图片

( 链路聚合示意图)


Eth-Trunk 可分为手工负载分担模式 LACP 模式


手工负载分担模式 Eth-Trunk 接口

手工负载分担模式是一种最基本的链路聚合方式。在该模式下,Eth-Trunk 的建立,成员接口的加入,以及哪些接口作为活动接口完全由手工来配置,没有链路聚合控制协议的参与。该模式下所有活动接口都参与数据的转发,分担负载流量,因此称为负载分担模式。如果活动链路中出现故障链路,链路聚合组自动在剩余的活动链路中平均分担数据流量。


LACP(Link Aggregation Control Protocol)模式 Eth-Trunk 接口

其中,最常用的是手工负载分担方式,使用该案例可以解决你工作中20% 的配置需求。


配置手工负载分担模式链路聚合


如图所示,Switch 和 SwitchA 之间用 Eth-Trunk 链路连接。要求 Switch 和 SwitchA之间的链路有较高的可靠性,手工 Eth-Trunk 主要适用于直连设备。


图片

(配置手工负载分担模式链路聚合组网图)


配置思路

采用如下的思路配置负载分担链路聚合:

1. 创建 Eth-Trunk;

2. 加入成员接口。


配置举例

● 创建 Eth-Trunk

#   创建 Eth-Trunk 120。

system-view

[Quidway] sysname Switch

[Switch] interface eth-trunk 120

[Switch-Eth-Trunk120] quit


● 向 Eth-Trunk 中加入成员接口

#   将 GE2/0/0 加入 Eth-Trunk 120。

[Switch] interface gigabitethernet 2/0/0

[Switch-GigabitEthernet2/0/0] eth-trunk 120

[Switch-GigabitEthernet2/0/0] quit

#   将 GE3/0/0 加入 Eth-Trunk 120。

[Switch] interface gigabitethernet 3/0/0

[Switch-GigabitEthernet3/0/0] eth-trunk 120

[Switch-GigabitEthernet3/0/0] quit


● 配置 Eth-Trunk 120

#   配置 Eth-Trunk 120 允许 VLAN100-200 的报文通过。

[Switch] interface eth-trunk 120

[Switch-Eth-Trunk120] port link-type trunk

[Switch-Eth-Trunk120] port trunk allow-pass vlan 100 to 200

[Switch-Eth-Trunk120] quit


●验证配置结果

在任意视图下执行 display trunkmembership 命令,检查 Eth-Trunk 120 是否创建成功,及成员接口是否正确加入。

图片

从以上信息看出 Eth-Trunk 120 中包含 2 个成员接口 GE2/0/0 和 GE3/0/0。成员接口的状态都为 Up。


配置文件

Switch 的配置文件

#

sysname Switch

#

interface Eth-Trunk120

port link-type trunk

port trunk allow-pass vlan 100 to 200

#

interface GigabitEthernet2/0/0

eth-trunk 120

#

interface GigabitEthernet3/0/0

eth-trunk 120

#

return


分享到: